Задать вопрос
31 марта, 07:08

Найти наименьший делитель числа n, отличный от 1.

+4
Ответы (1)
  1. 31 марта, 09:49
    0
    Var

    i, n: integer;

    begin

    write ('Введите число ') ;

    Readln (n) ;

    for i : = 2 to n do

    if (n mod i) = 0 then begin

    write ('Наименьший делитель равен ', i) ;

    Break;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти наименьший делитель числа n, отличный от 1. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Проверить являются ли два введенных числа дружественными. Дружественные числа - пара чисел, каждое из которых равно сумме собственных делителей другого (Делителем числа называется всякий его делитель, отличный от самого числа) Дружественные числа
Ответы (1)
Задачи в паскаль: Цикл с предусловием а) Найти наименьшее общее кратное двух заданных натуральных чисел. б) Дано натуральное число. Найти его наименьший делитель, отличный от 1. Помогите, решить!
Ответы (2)
Что такое пиксель? 1) это наименьший элемент компьютера, получаемого с помощью специальных приборов 2) это наименьший элемент изображения, получаемого с помощью компьютерного монитора или принтера 3) это наименьший элемент программы, записанной на
Ответы (2)
Найдите минимальный натуральный делитель, отличный от 1, числа 1000000013 (109+13109+13), то есть такое минимальное натуральное число d>1d>1, что 109+13109+13 делится нацело на dd.
Ответы (1)
Найдите минимальный натуральный делитель, отличный от 1, числа 1000000013 (10^9+13), то есть такое минимальное натуральное число d>1, что 10^9+13 делится нацело на d.
Ответы (1)