Задать вопрос
3 февраля, 18:11

Сформировать массив простых чисел не больших заданного натурального числа N

это паскаль.

+2
Ответы (1)
  1. 3 февраля, 19:09
    0
    Const m=1000;

    var

    a:array[1 ... m] of integer;

    n, i, p, k, j:integer;

    begin

    write ('n = ') ; readln (n) ;

    i:=0; p:=1;

    while p
    begin

    k:=0;

    for j:=2 to round (sqrt (p)) do

    if p mod j = 0 then k:=k+1;

    if k=0 then begin i:=i+1; a[i]:=p; end;

    p:=p+1;

    end;

    for j:=1 to i do write (a[j],' ') ;

    writeln;

    end.

    Пример:

    n = 100

    1 2 3 5 7 11 13 17 19 23 29 31 37 41 43 47 53 59 61 67 71 73 79 83 89 97
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Сформировать массив простых чисел не больших заданного натурального числа N это паскаль. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Язык Паскаль. №1 Дан массив, состоящий из n натуральных чисел. Образовать новый массив, элементами которого будут элементы исходного, оканчивающиеся на цифру k. №2 Дан масив целых числ. Найти в этом массиве минимальный элмент m и максимальный M.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Visual basic 1. Сформировать одномерный массив из восьми вещественных значений. 2. Сформировать двумерный массив из А строк и В столбцов. 3. Составить программу для определения максимального и минимального элементов двумерного массива. 4.
Ответы (1)
Сформировать массив А из 30 случайных целых чисел в диапазоне от-30 да 50. Сформировать массивы С, В которые содержат: массив В - четные элементы из массива А в порядке их следования в массиве А, массив С - отрицательные элементы массива А в
Ответы (1)
1. Сформировать текст заданной длины, состоящий из 2 символов А и В. 2. Найдите количество символов заданного числа 25 3. Написать программу обращения заданного слова (вывести символы строки в обратном порядке). (слово привет) 4.
Ответы (1)