Задать вопрос
14 октября, 04:02

1. Дана последовательность целых чисел a, b, c. Найти минимальное из них, и разделить на него все числа. Входные данные вводятся пользователем с экрана. Вывод так же осуществляется на экран.

+5
Ответы (1)
  1. 14 октября, 05:12
    0
    Var a, b, c, min:integer; a1, b1, c1:real;

    begin

    write ('a=') ; readln (a) ;

    write ('b=') ; readln (b) ;

    write ('c=') ; readln (c) ;

    if a
    if c
    a1:=a/min; b1:=b/min; c1:=c/min;

    writeln ('min=', min) ;

    writeln ('a1=', a1:5:2,' b1=', b1:5:2,' c1=', c1:5:2) ;

    end.

    Пример работы программы:

    a=43

    b=28

    c=37

    min=28

    a1 = 1.54 b1 = 1.00 c1 = 1.32
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. Дана последовательность целых чисел a, b, c. Найти минимальное из них, и разделить на него все числа. Входные данные вводятся ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Написать в паскаль вычислить значение выражения y=|x|-2*|z|. Входные данные вводятся пользователем с экрана. Вывод так же на экран
Ответы (1)