Задать вопрос
30 августа, 10:32

Язык программирования Pascal

Среди всех трёхназчных чисел посчитать количество кратных 5. Найти их среднее арифметическое.

+3
Ответы (1)
  1. 30 августа, 11:03
    0
    Var a, b, c:integer;

    begin

    b:=0;

    for a:=100 to 999 do begin

    if (a mod 5 = 0) then begin b:=b+1; c:=c+a; end;

    end;

    writeln ('чисел делящихся на 5 = > ', b) ;

    writeln ('среднее арифметическое чисел делящихся на 5 = > ', c/b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Язык программирования Pascal Среди всех трёхназчных чисел посчитать количество кратных 5. Найти их среднее арифметическое. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Напишите программу, которая в последовательности целых чисел находит среднее арифметическое чисел, кратных 9, или сообщает, что таких чисел нет.
Ответы (1)
20.2 (№ 987) Напишите программу, которая в последовательности натуральных чисел находит среднее арифметическое чисел, кратных 8, или сообщает, что таких чисел нет (выводит "NO").
Ответы (1)