Задать вопрос
23 сентября, 21:27

Дан файл, содержащий различные даты. Каждая дата - это

число, месяц и год. Найти год с наименьшим номером. Паскаль

+3
Ответы (1)
  1. 23 сентября, 23:02
    0
    Программа будет работать, если каждая дата записана в отдельной строке, причем число, месяц и год отделяются пробелом

    var f:text;

    d, m, y, min:integer;

    begin

    Assign (f,'date. txt') ;

    Reset (f) ;

    min:=9999;

    while not eof (f) do

    begin

    readln (f, d, m, y) ;

    if y
    end;

    Close (f) ;

    writeln ('min=', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дан файл, содержащий различные даты. Каждая дата - это число, месяц и год. Найти год с наименьшим номером. Паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Сравнение файлов Первый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Фоксфорд олимпиада по информатикеПервый файл на 1 мегабайт больше, чем второй файл. Второй файл на 3072 байта больше, чем третий файл. На сколько килобайт третий файл меньше, чем первый? В ответе укажите только число, слово "килобайт" писать не надо.
Ответы (1)
Почему файл, созданный в Word 2007, имеет расширение. docm? Вариант 1 файл предназначен для пересылки по электронной почте Вариант 2 файл содержит вирусы Вариант 3 файл создан на основе шаблона Вариант 4 файл содержит макросы
Ответы (1)
Решение задач с использованием файлов 1. Дано число к и файл, содержащий целые числа. Вывести элемент файла с номером к. если такой элемент отсутствует, то вывести 0. 2. Дан файл вещественных чисел.
Ответы (1)