Задать вопрос
4 февраля, 17:41

Найти сумму всех элементов линейного массива меньших чем произвольное число K

+1
Ответы (1)
  1. 4 февраля, 20:56
    0
    Const

    handsfree = true;

    var

    a: array[1 ... 100] of real;

    i, n: integer;

    t, sum: real;

    begin

    {ввод массива}

    if handsfree then

    n : = random (20) + 5

    else begin

    write ('n = ') ;

    readln (n) ;

    end;

    writeln ('Данные массива:') ;

    for i : = 1 to n do

    begin

    if handsfree then begin

    a[i] : = random (100) ;

    write (a[i], ' ') ;

    end

    else readln (a[i]) ;

    end;

    writeln () ;

    {подсчет элементов}

    write ('k = ') ;

    readln (t) ;

    sum : = 0;

    for i : = 1 to n do

    if a[i] < t then sum : = sum + a[i];

    writeln ('sum = ', sum) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти сумму всех элементов линейного массива меньших чем произвольное число K ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Помогите решить задачи в паскале. 1) найти сумму положительных элементов массива. 2) найти сумму четных элементов массива. 3) найти сумму всех четных элементов массива, стоящих на четных местах.
Ответы (1)