Задать вопрос
27 ноября, 11:27

Заполнить случайными числами в диапазоне от 1 до 10 массив A[N]. Найти в получившемся массиве наиболее часто встречающееся число. Если таких чисел несколько, то вывести наименьшее из них. Вывести на экран сам массив и получившееся число. Протестировать программу на трёх произвольных тестах, доказав правильность её работы.

+3
Ответы (1)
  1. 27 ноября, 13:41
    0
    Значит так: мы создаем массив избыточной длины, куда потом будем записывать рандомные числа. Так же мы создаем массив-счетчик b (у него индексами являются сами числа, а элементами - количество этого числа в массиве А), куда будет присваиваться, сколько раз нам встречается то или иное число (перед этим мы массив обязательно обнулим). В конце мы смотрим максимальное число из массива-счетчика. Вуаля!

    Вот пример программы на паскале ABC:

    var a:array [1 ... 1000000] of integer;

    b:array [1 ... 10] of longint;

    c:integer;

    i, max, n:longint;

    begin

    write ('Введите число элементов массива: ') ;

    readln (n) ;

    max:=0;

    for i:=1 to 10 do

    b[i]:=0;

    for i:=1 to n do begin

    a[i]:=random (10) + 1;

    write (a[i],' ') ;

    b[a[i]]:=b[a[i]]+1

    end;

    for i:=1 to 10 do if b[i]>max then

    begin

    c:=i;

    max:=b[i]

    end;

    writeln;

    writeln ('Чаще всего в массиве встречается число ', c)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполнить случайными числами в диапазоне от 1 до 10 массив A[N]. Найти в получившемся массиве наиболее часто встречающееся число. Если ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Разработать схему алгоритма, который вводит массив из Nцелых чисел и выводит на экран этот же массив в прямом и обратном порядке. Протестировать алгоритм на произвольных массивах, состоящих из 1 числа, из 5 чисел, из 10 чисел. 2.
Ответы (2)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
1. Заполнить массив а [1 ... 14] случайными целыми числами в диапазоне от 1 до 18 и вывести на экран элементы массива с нечетными значениями, меньшими 10. 2. Заполнить массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)