Задать вопрос
13 января, 20:21

Алгоритм вычисление функции Fn, где n=натуральное число, задан следующими соотношениями:

F1=1; F2=1;

Fn=Fn-2+Fn-1 при n<2

Чему равно F5?

+5
Ответы (1)
  1. 13 января, 23:00
    0
    Вот программа:

    var f1, f2, fn, i:integer;

    begin

    f1:=1; f2:=1;

    for i:=3 to 8 do

    begin

    fn:=f1+f2; f1:=f2; f2:=fn;

    end;

    writeln ('fn=', fn) ;

    end.

    F3=F1+F2=1+1=2

    F4=F2+F3=1+2=3

    F5=F3+F4=2+3=5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Алгоритм вычисление функции Fn, где n=натуральное число, задан следующими соотношениями: F1=1; F2=1; Fn=Fn-2+Fn-1 при n ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими соотношениями: F (1) = 1, F (2) = 1 F (n) = F (n-2) * (n-1) + 2, при n > 2 Чему равно значение функции F (8) ? В ответе запишите только натуральное число.
Ответы (1)
Помогите! Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими рекуррентными соотношениями: F (n) = 2 при n = 1 F (n) = F (n - 1) · n при n ≥ 2. Чему равно значение функции F (5) ?
Ответы (2)
Алгоритм вычисления значения функции F (n) и G (n), где n - натуральное число, задан следующими соотношениями: F (1) = 0 F (n) = F (n-1) + n, при n >1 G (1) = 1 G (n) = G (n-1) * n, при n >1 Чему равно значение функции F (5) + G (5) ?
Ответы (1)
Алгоритм вычисления функции F (n), где n-натуральное число, задан следующими соотношениями: F (1) = 1; F (2) = 2, F (n) = F (n-1) + n при n>2 Чему равно значение функции F (6) ?
Ответы (1)
Алгоритм вычисления значения функции F (n), где n - натуральное число, задан следующими соотношениями F (1) = 1 F (n) = 18 - F (n-1) * (2*n + 1), при n > 1 Чему равно значение функции F (5) ?
Ответы (1)