Задать вопрос
10 января, 05:06

Составьте программу для нахождения минимального элемента массива Х, состоя-

щего из 6 элементов, значения которых рассчитываются по формуле

X = (sini-1) / 2cosi+1

Язык Турбо Паскаль

+3
Ответы (1)
  1. 10 января, 07:49
    0
    Const n=6;

    var x:array[1 ... n] of real;

    min:real; i:integer;

    begin

    for i:=1 to n do

    x[i]: = (sin (i) - 1) / (2*cos (i)) + 1;

    min:=x[1];

    for i:=2 to n do

    if x[i]
    writeln ('min=', min:5:3) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу для нахождения минимального элемента массива Х, состоя- щего из 6 элементов, значения которых рассчитываются по формуле ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)