Задать вопрос
28 июня, 17:45

Среди чисел от a до b найти сумму четных и и количество кратных 5. Желательно сотавить блок-схему и программу

+2
Ответы (1)
  1. 28 июня, 18:07
    0
    Программа для решения задачи:

    var a, b, sum, k, i:integer;

    begin

    write ('Введите a=') ; readln (a) ;

    write ('Введите b=') ; readln (b) ;

    sum:=0; k:=0;

    for i:=a to b do

    begin

    / / если число делится на 2 без остатка, то добавляем его к сумме

    if i mod 2 = 0 then sum:=sum+i;

    / / если число делится на 5 без остатка, то увеличиваем количество на 1

    if i mod 5 = 0 then k:=k+1;

    end;

    / / выводим результат

    writeln ('sum=', sum) ;

    writeln ('k=', k) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Среди чисел от a до b найти сумму четных и и количество кратных 5. Желательно сотавить блок-схему и программу ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
1) Напишите программу которая в последствии натуральных чисел определяет, находит сумму двузначных чисел не кратных 4. В последовательности обязательно имеется двузначное число не кратное 4.
Ответы (1)
Напишите программу, которая в последовательности натуральных чисел определяет количество всех чётных чисел, кратных 3.
Ответы (1)
Напишите программу, которая в последовательности целых чисел определяет количество четных чисел, кратных 3. Программа получает на вход целые числа.
Ответы (1)
Напишите программу на языке Паскаль, которая в последовательности целых чисел определяет количество четных чисел кратных 3. Программа получает на выход целые числа.
Ответы (1)