Задать вопрос
23 января, 05:26

Составить программу обработки массива F (21). Каждый третий элемент массива F возвести в квадрат, если элемент отрицательный. Эти значения напечатать. Pascalabc (9 класс)

+5
Ответы (1)
  1. 23 января, 05:38
    0
    Var

    i: integer;

    f: array[1 ... 21] of integer;

    begin

    randomize;

    for i : = 1 to 12 do

    begin

    f[i]:=random (21) - 10;

    if (i mod 3 = 0) and (f[i]<0) then f[i]:=sqr (f[i]) ;

    writeln (f[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу обработки массива F (21). Каждый третий элемент массива F возвести в квадрат, если элемент отрицательный. Эти значения ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
Паскаль! Дан массив А размерностью N. Записать в каждый элемент массива В следующие значения: 1 ый элемент - сумма всех нечетных элементов массива А; 2 ои элемент - сумма всех четных элементов массива А: Зий элемент - сумма всех элементов массива А
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Если хотя бы один элемент однородного массива отрицательный, то вывести сообщение элемент отрицательный, если иначе - все положительные.
Ответы (1)