Задать вопрос
9 марта, 23:29

У исполнителя Умножатор две команды, которым присвоены номера:

1. умножь на 3

2. прибавь 2

Первая из них увеличивает число на экране в 3 раза, вторая - прибавляет к числу 2. Составьте алгоритм получения из числа 2 числа 66, содержащий не более 5 команд. В ответе запишите только номера команд. В ответе запишите только номера команд. (Например, 12212 - это алгоритм: умножь на 3, прибавь 2, прибавь 2, умножь на 3, прибавь 2, который преобразует число 2 в 32.) Если таких алгоритмов более одного, то запишите любой из них.

+2
Ответы (2)
  1. 10 марта, 02:35
    0
    Ответ: 11221

    Ход решения:

    Procedure Find (a : Integer; s : String) ;

    Begin

    If a=66 then Writeln (s) ;

    If Length (s) <5 then

    Begin

    Find (a*3, s+'1') ;

    Find (a+2, s+'2') ;

    end;

    end;

    Begin

    Find (2,'') ;

    end.
  2. 10 марта, 03:02
    0
    Начнем с конца.

    66 (делим на 3) [1]

    22 (на 3 не делится, значит отнимаем 2) [2]

    20 (на 3 не делится, значит отнимаем 2) [2]

    18 (делим на 3) [1]

    6 (делим на 3) [1]

    2

    Ответ: 11221
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «У исполнителя Умножатор две команды, которым присвоены номера: 1. умножь на 3 2. прибавь 2 Первая из них увеличивает число на экране в 3 ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
исполнителя Удвоитель две команды, У исполнителя Удвоитель две команды, которым присвоены номера: 1. умножь на 2.2. прибавь 3 Первая из них увеличивает число на экране 2 раза, вторая - прибавляет к числу 3.
Ответы (1)
У исполнителя Вычислитель две команды, которым присвоены номера: 1. умножь на 2 2. вычти 1 Первая из них увеличивает число на экране в 2 раза, вторая уменьшает его на 1. Составьте алгоритм получения из числа 9 числа 29, содержащий не более 5 команд.
Ответы (1)
У исполнителя Вычислитель две команды, которым присвоены номера: 1. умножь на 3 2. вычти 1 Первая из них увеличивает число на экране в 3 раза, вторая уменьшает его на 1. Составьте алгоритм получения из числа 1 числа 23, содержащий не более 5 команд.
Ответы (1)
Помогите решить задачу. У исполнителя Вычислитель две команды, которым присвоены номера: 1) умножь на 3 2) прибавь 1 Первая из них увеличивает число на экране в 3 раза, вторая увеличивает его на 2.
Ответы (1)
У исполнителя Вычислитель две команды, которым присвоены номера: 1. умножь на 3 2. прибавь 2 Первая из них увеличивает число на экране в 3 раза, вторая увеличивает его на 2.
Ответы (1)