Задать вопрос
1 марта, 08:55

Дана последовательность оператора:

a:=1;

b:=2;

while a+b<8 do

begin

a:=a+1

b:=b+2

end;

s:=a+b

Сколько раз будет повторен цикл и какими будут значения переменных a, b, s после исполнения этой последовательности оператор?

+3
Ответы (1)
  1. 1 марта, 12:13
    0
    Код полностью var

    a, b, s: real;

    begin

    a : = 1;

    b : = 2;

    while a + b < 8 do

    begin

    a : = a + 1;

    b : = b + 2;

    writeln ('a = ', a, ' b = ', b) ;

    end;

    s : = a + b;

    writeln ('s = ', s) ;

    end.

    вывод

    a = 2 b = 4

    a = 3 b = 6

    s = 9

    Отсюда видно что цикл прокрутился 2 раза и a = 3 b = 6 s = 9
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дана последовательность оператора: a:=1; b:=2; while a+b ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. определить значение переменной А после выполнения оператора X:=5; if X>-3 then A:=X mod 2 else A:=abs (X) ; 2. определить значение переменной А после выполнения оператора X:=-26; Y:=6; if X div Y=4 then A:=X mod Y else A:=X*Y; 3.
Ответы (1)
В результате выполнения некого оператора переменные получили следующие значения a=3, c=9 укажите правильную запись данного оператора.
Ответы (1)
При выполнении оператора c:=8 в ячейку оперативной памяти компьютера с именем c заносится значение () ; при выполнении оператора g:=101 в ячейку оперативной памяти компьютера с именем g заносится значение () .
Ответы (1)
Дана последовательность операторов: a:=1; b:=1; While a+b
Ответы (1)