Задать вопрос
15 июля, 20:49

Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее значение его элементов.

программа: Pascal ABC.

+5
Ответы (2)
  1. 15 июля, 21:24
    0
    Var A:array[1 ... 25] of Integer;

    i:integer;

    S:real;

    begin

    Readln (N) ;

    For i:=1 to 25 do

    Readln (A[i]) ;

    For i:=1 to 25 do

    S:=S+A[i];

    S:=S/25;

    Writeln (S) ;

    end.
  2. 15 июля, 22:50
    0
    Const

    n = 25;

    var

    a: array[1 ... n] of integer;

    i, s: integer;

    begin

    Writeln ('Введите элементы массива') ;

    s : = 0;

    for i : = 1 to n do

    begin Read (a[i]) ; s : = s + a[i] end;

    Writeln ('Среднее значение элементов массива равно ', s/n)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу, которая находит сумму элементов массива (25 целых чисел, которые вводятся с клавиатуры), и выводит на экран среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) Составьте программу на языке Pascal, в которой пользователь вводит с клавиатуры значения элементов массива, а программа выводит значения элементов массива с противоположным знаком.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Задание 1: Составьте программу ввода с клавиатуры массива целых чисел a[1 ... 10] и вывода на экран элементов массива с нечетными значениями. Задание 2:Составьте программу ввода с клавиатуры массива целых чисел a[1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)