Задать вопрос
21 марта, 04:55

Основы программирования на языке paskal

Записать на языке:

A) если x четное или y четное, то с - это их среднее арифметическое, а иначе с - это остаток от деления x на y.

Б) для k от 1 до 15 найди сумму значений параметра

В) удваивай x пока оно не превысит 100

Г) поменяй значения a и b местами

+2
Ответы (1)
  1. 21 марта, 05:16
    0
    Var x, y, c, k, i, a, b:integer;

    begin

    readln (x, y, a, b) ;

    If (x mod 2=0) or (y mod 2=0) then

    c: = (x+y) div 2

    else

    c:=x mod y;

    For i:=1 to 15 do

    k:=k+i;

    While x<=100 do

    x:=x*2;

    a:=a+b;

    b:=a-b;

    a:=a-b;

    Writeln (c,' ', k,' ', x,' ', a,' ', b) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Основы программирования на языке paskal Записать на языке: A) если x четное или y четное, то с - это их среднее арифметическое, а иначе с - ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Записать на языке Pascal следующие фразы: а) Даны три числа a, b, c. b) Если x четное или y четное, то с-это их среднее арифметическое, а иначе с-это остаток от деления x на y. c) Для k от 1 до 15 найди сумму значений параметра.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Составь алгоритм решения задачи: расположи три числа 4,8,2 в порядке убывания. 1) Начало 2) Сравни первое и второе числа; если первое ... второго, то поменяй их местами. 3) Сравни второе и третьего числа; если второе ...
Ответы (1)
Составить программу, которая находит минимальное натуральное число х, такое, что остаток от деления х на 10 равен 9, остаток от деления х на 9 равен 8, остаток от деления х на 8 равен 7, ... остаток от деления х на 2 равен 1.
Ответы (1)
Автомат получает на вход нечётное число X. По этому числу строится трёхзначное число Y по следующим правилам. 1. Первая цифра числа Y (разряд сотен) - остаток от деления X на 4. 2. Вторая цифра числа Y (разряд десятков) - остаток от деления X на 3.
Ответы (1)