Задать вопрос
16 июня, 23:44

Найти наибольшее значение элементов двумерного массива паскаль

+5
Ответы (1)
  1. 17 июня, 03:11
    0
    Const

    handsfree = true;

    var

    a: array[1 ... 100, 1 ... 100] of real;

    max, min: real;

    i, j, m, n: integer;

    begin

    {ввод матрицы}

    if handsfree then begin

    n : = random (20) + 2;

    m : = random (20) + 2;

    end

    else begin

    write ('n, m = ') ;

    readln (n, m) ;

    end;

    writeln ('Данные матрицы') ;

    for i : = 1 to m do

    begin

    for j : = 1 to n do

    if handsfree then begin

    a[i, j] : = random (100) - 50;

    write (a[i, j]:4, ' ')

    end

    else

    read (a[i, j]) ;

    writeln;

    end;

    {минимумы и максимумы}

    max : = a[1, 1];

    min : = a[1, 1];

    for i : = 1 to m do

    for j : = 1 to n do

    begin

    if max < a[i, j] then max : = a[i, j];

    if min > a[i, j] then min : = a[i, j];

    end;

    writeln ('max = ', max) ;

    writeln ('min = ', min) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти наибольшее значение элементов двумерного массива паскаль ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
Построить из элементов двумерного массива одномерный массив, элементом которого являетются четные элементы двумерного массива
Ответы (1)