Задать вопрос
25 марта, 08:02

Определить сумму всех элементов массива, расположенных над

главной диагональю

+2
Ответы (1)
  1. 25 марта, 10:11
    0
    Const

    n=3;

    var a:array[1 ... n, 1 ... n] of integer;

    i, j, s:integer;

    begin

    s:=0;

    writeln ('Введите элементы матрицы') ;

    for i:=1 to n do

    for j:=1 to n do begin

    read (a[i, j]) ;

    if i
    end;

    writeln;

    for i:=1 to n do begin

    for j:=1 to n do write (a[i, j], ' ') ;

    writeln;

    end;

    writeln ('Сумма всех элементов над главной диагональю = ', s) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определить сумму всех элементов массива, расположенных над главной диагональю ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)
Составить программу на языке Паскаль: 1) Для массива K из 12 вещественных чисел определить сколько элементов массива меньше 0. 2) В массиве М из 10 целых чисел найти количество элементов равных 3.
Ответы (1)
В одномерном массиве, состоящем из n элементов, вычислить: 1) количество отрицательных элементов массива, расположенных на четных местах 2) сумму четных элементов массива, расположенных на нечетных местах.
Ответы (1)