Задать вопрос
6 августа, 13:09

Написать программу вычисления факториала с использованием рекурсивной подпрограммы

+2
Ответы (1)
  1. 6 августа, 16:55
    0
    Var n:integer;

    Function Factorial (n : Integer) : Integer;

    Begin If n = 1 then Factorial : = 1

    Else Factorial : = n*Factorial (n-1) ;

    End;

    begin

    readln (n) ;

    write (factorial (n)) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу вычисления факториала с использованием рекурсивной подпрограммы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
Задачу решить двумя способами: с использованием подпрограммы-функции и подпрограммы-процедуры. Обязательно построение блок-схем алгоритмов! 1. Треугольник задан координатами своих вершин.
Ответы (1)
Задание 5 Вопрос: При помощи чего записываются вспомогательные алгоритмы на языке Паскаль? Выберите один из 4 вариантов ответа: 1) Тесты 2) Подзадачи 3) Подпрограммы 4) Подкоманды Задание 6 Вопрос: Какие существуют подпрограммы в языке Паскаль?
Ответы (1)
Составить программу вычисления факториала целого положительного числа N! с использованием цикла for.
Ответы (1)
1. Напишите программу вычисления расстояния между двумя точками плоскости. 2. Напишите программу вычисления площади боковой поверхности куба. 3. Напишите программу вычисления площади и гипотенузы прямого треугольника, если известны его катеты. 4.
Ответы (1)