Задать вопрос
12 марта, 08:52

Напишите программу на языке Pascal, которая с помощью цикла for to считала s:=1-2+3-4+5-6+7-8+9-10 ...

+2
Ответы (2)
  1. 12 марта, 09:09
    0
    Var n, s, i:integer;

    begin

    write ('введите n ') ;

    readln (n) ;

    for i:=1 to n do if i mod 2 0 then s:=s+i else s:=s-i;

    writeln ('s = ', s) ;

    end.
  2. 12 марта, 11:49
    0
    Var n, i, s:integer;

    begin

    write ('n = ') ; readln (n) ;

    s:=0;

    for i:=1 to n do

    if i mod 2 = 0 then s:=s-i else s:=s+i;

    writeln ('s = ', s) ;

    end.

    Пример:

    n = 10

    s = - 5
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите программу на языке Pascal, которая с помощью цикла for to считала s:=1-2+3-4+5-6+7-8+9-10 ... ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сколько раз будет выполнено тело цикла? А. for i:=-5to5 do тело цикла; В. for i:=6 to 2 do тело цикла; С. for i: = 3to 3 do тло цикла; D. for i:=3 downto 4 do тело цикла E. for i : = 3 downto 1 do тело цикла
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
Для чего используются команды цикла? Как записывается команда цикла FOR? Как в цикле записать команду присваивания, чтобы она вычисляла сумму чисел? Количество?
Ответы (2)
Задание: 1) Перечислить виды циклов. 2) Конструкция цикла с параметром на языке программирования Pascal. 3) Известно ли число повторений в цикле с параметром? 4) Если известно, то указать формулу, по которой можно определить число повторений.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)