Задать вопрос
25 ноября, 09:15

Задание: Составьте программу ввода с клавиатуры элементов массива a[1 ... 10] и вывода на экран элементов, значения которых являются квадратами целых чисел. Вот что я составил, но извлечение корня нельзя делать в integer: (Помогите! Program shist;

Var a: array [1 ... 10] of integer;

i: integer;

Begin

writeln ('ВВедите элементы массива:') ;

readln (i) ;

writeln ('Элементы массива, значения которых являются квадратами целых чисел:') ;

For i:=1 to 10 do

if sqrt (i) then

write (a[i], ' ')

End.

+3
Ответы (1)
  1. 25 ноября, 10:37
    0
    Текст программы на языке Паскаль:

    program _1;

    const N=10;

    var i: integer;

    a: array[1 ... N] of integer;

    begin

    for i:=1 to N do begin

    readln (a[i]) ;

    a[i]:=a[i]*a[i];

    end;

    for i:=1 to N do begin

    writeln (a[i]) ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Задание: Составьте программу ввода с клавиатуры элементов массива a[1 ... 10] и вывода на экран элементов, значения которых являются ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике