Задать вопрос
28 декабря, 12:25

Паскаль! дано треззначное число. найти: а) число единиц в нем, b) число десятков в нем, c) сумму его цифр, d) произведение его цифр

+1
Ответы (1)
  1. 28 декабря, 15:19
    0
    Var a, b, c, d, e, f:integer;

    begin

    readln (a) ;

    b:=a mod 10;

    c:=a div 10 mo 10;

    d:=a div 100;

    e:=b+c+d;

    f:=b*c*d;

    writeln ('Число единиц:', b) ;

    writeln ('Число десятков:', c) ;

    writeln ('Сумма цифр:', e) ;

    writeln ('Произведение цифр:', f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Паскаль! дано треззначное число. найти: а) число единиц в нем, b) число десятков в нем, c) сумму его цифр, d) произведение его цифр ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано натуральное число: определить а) количество цифр в нем б) сумму его цифр в) произведение его цифр г) среднее арифметическое его цифр д) сумму квадратов его цифр е) сумму кубов его цифр ж) его первую цифру з) сумму его первой и последней цифр
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1. Дано трехзначное число. Найти число единиц в нем число десятков в нем сумму его цифр произведение его цифр 2. Дано трехзначное число. Найти число. Найти число, полученное при прочтении его цифр справа налево
Ответы (1)
Дано трехзначное число. Найти число единиц в нем, число десятков в нем, число сотен в нем, сумму его цифр, произведение его цифр
Ответы (1)
Напишите программу на паскале, которая 1) сначала определит по введенному двузначному числу цифру десятков и цифру единиц. 2.1) Если цифра десятков меньше цифры единиц, то программа выведет двузначное число, состоящее из. цифр единиц.
Ответы (1)