Задать вопрос
2 февраля, 11:49

Написать программу вычисления наименьшего элемента массива.

+3
Ответы (1)
  1. 2 февраля, 15:02
    0
    Для языка программирования: Turbo Pascal

    program min;

    var a: array [1 ... 10] of integer;

    i, p: byte; min: integer;

    begin writeln ('Массив:') ;

    for i:=1 to 10 do

    begin a[i]:=-20+random (80) ;

    write (a[i],' ') ;

    end;

    writeln () ;

    min:=a[1];

    for i:=1 to 10 do

    if (a[i] < = min) then

    begin min:=a[i]; p:=i;

    end;

    writeln ('Минимальное число = ', min,' его порядковый номер = ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу вычисления наименьшего элемента массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Дан массив 1 2 3 4 5 6 7 8 7 0 - 8 - 4 2 16 - 10 2 А Определите: А) размерность массива; Б) значение элемента А[3]; В) значение максимального элемента массива; Г) индекс первого отрицательного элемента массива;
Ответы (1)
Заменить значение каждого элемента каждой строки массива А на значение соответствующего элемента соответствующего столбца массива В (1-й элемент 1-й строки массива А на 1-й элемент 1-го столбца массива В, 2-й элемент 1-й строки массива А на 2-й
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Что определяет для массива X[1 ... n] следующий алгоритм R: = n; For k: = 1 to n do If X[k]
Ответы (1)