Задать вопрос
12 ноября, 08:17

Нарисовать блок-схему и программу по этой схеме на языке с++.

В массиве записаны результаты 20 игр футбольной команды (если игра окончилась выигрышем данной команды, то записать число 3, проигравшим 2, если игра закончилась вничью - 1). Определить количество выигрышей, количество ничьих и количество проигрышей данной команды.

+5
Ответы (1)
  1. 12 ноября, 11:32
    0
    Блок-схема - в прилагаемом файле.

    Программа:

    #include

    #include

    using namespace std;

    int main () {

    const int n = 20;

    int a[n];

    int k1=0;

    int k2=0;

    int k3=0;

    srand (time (0)) ;

    for (int i = 0; i < n; i++) {

    a[i]=rand () % 3 + 1;

    cout << a[i] << " ";

    }

    cout <<"/n";

    for (int i = 0; i < n; i++) {

    switch (a[i]) {

    case 1:

    k1++; break;

    case 2:

    k2++; break;

    case 3:

    k3++; break;

    }

    }

    cout << "k1 = " << k1 << " k2 = " << k2 << " k3 = " << k3 <<"/n";

    return 0;

    }

    Пример:

    2 1 2 1 2 1 3 3 2 3 1 3 1 2 3 2 1 3 3 3

    k1 = 6 k2 = 6 k3 = 8
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нарисовать блок-схему и программу по этой схеме на языке с++. В массиве записаны результаты 20 игр футбольной команды (если игра окончилась ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Даны три одномерных массива. Упорядочить их по возрастанию элементов. Составить программу проверки, сколько раз повторяется заданное число в каждом массиве.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)
Петя за три года купил 20 компьютерных игр. В первый год он купил 6 игр. Известно, что в течение первого и второго годов он купил игр в три раза больше, чем в третий год. Сколько компьютерных игр купил Петя на второй год? Можно полное решение
Ответы (2)
Какая формула соответствует поиску документа с любым из трех слов? Игра| Инженер | Задача Игра Инженер Задача "Игра * Инженер Задача" "Игра Инженер Задача" Игра + Инженер + Задача Игра - Инженер + Задача
Ответы (1)
Какая формула соответствует поиску документа, который обязательно содержит все три слова? Игра| Инженер | Задача Игра Инженер Задача "Игра * Инженер Задача" "Игра Инженер Задача" Игра + Инженер + Задача Игра - Инженер + Задача
Ответы (1)