Задать вопрос
19 января, 21:40

На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две половины данного массива.

+1
Ответы (1)
  1. 19 января, 22:13
    0
    Const

    N = 5;

    var

    i: integer;

    a: array[1 ... N * 2 + 1] of integer;

    begin

    writeln ('Исходный массив: ') ;

    for i : = 1 to 2 * N do

    begin

    a[i] : = Random (99) + 1;

    write (a[i] : 5) ;

    end;

    for i : = 2 * N + 1 downto N + 1 do

    a[i] : = a[i - 1];

    a[N + 1] : = 0;

    writeln () ;

    writeln ('Полученный массив: ') ;

    for i : = 1 to 2 * N + 1 do

    write (a[i] : 5) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «На ленте машины Поста расположен массив из 2n ячеек. Составить программу, по которой машина Поста раздвинет на расстояние в одну ячейку две ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
На информационной ленте машины Поста расположен расположен массив из n меток. Каретка находится под крайней левой меткой. Какое состояние установится на ленте после выполнения следующей программы? 1 → 2 2 ↕ 3 3 → 4 4? 5,2 5 ← 6 6 v 7 7!
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
На информационной ленте машины поста расположен массив из N меток. Каретка находится под крайней левой меткой. Какое состояние установится на ленте после выполнения следующих программ: 1->2; 2 | 3; 3->4; 4? 5,2; 5
Ответы (1)
1. Сколько ячеек в диапазоне B5:D9? 2. Чтобы переместиться на одну ячейку вниз нужно нажать: а) tab б) enter в) клавиша "стрелка вниз" г) мышью 3.
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)