Задать вопрос
11 марта, 08:06

Составьте программу которая устанавливала бы нахождение повторяющихся букв в слове, т. е. показывала есть или нету.

+5
Ответы (1)
  1. 11 марта, 10:33
    0
    Вот решение на паскале ABC, если нужно на другом языке программирования. Напишите на почту.

    var

    a:string;

    c:char;

    n, i, i1:integer;

    begin

    readln (a) ;

    for i:=1 to length (a) do begin

    c:=a[i];

    for i1:=i+1 to length (a) do begin

    if c = a[i1] then n:=n+1;

    end;

    end;

    if n>0 then writeln ('В слове ', n,' пар букв') else writeln ('Буквы не повторяются')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составьте программу которая устанавливала бы нахождение повторяющихся букв в слове, т. е. показывала есть или нету. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)