Задать вопрос
5 марта, 08:17

Найти средние армфметические значения элементов столбцов двумерного массива.

Программа в Паскале

+1
Ответы (1)
  1. 5 марта, 11:19
    0
    Const nx=30;

    var i, j, n, m:integer; A:array[1 ... nx, 1 ... nx] of integer; B:array[1 ... nx] of real;

    Sn:real;

    begin

    Write ('Введите размер массива ') ; Readln (n) ;

    for j:=1 to n do begin

    for i:=1 to n do begin

    A[i, j]:=random (100) - 2;

    m: = m + A[i, j]; end;

    Sn: = m/n; B[j]: = Sn; Sn: = 0.0; m:=0; end;

    for i:=1 to n do begin

    for j:=1 to n do begin

    write (A[i, j]:9) ; end;

    writeln; end;

    for j:=1 to n do

    write (B[j]:9:4) ; end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Найти средние армфметические значения элементов столбцов двумерного массива. Программа в Паскале ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
Написать программу обработки двумерного массива: дан массив А 15 строк и 15 столбцов. Заполнить массив случайными числами, найти мах, мин, и сумму элементов всего массива Нужно в тетраде написать Нужно написать так, как в паскале
Ответы (1)
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
Паскаль, составьте программу для двумерного массива: Найти произведение отрицательных элементов указанной строки двумерного массива размером 4*5 целых чисел.
Ответы (1)