Задать вопрос
6 октября, 15:31

7. Текстовый файл. Паскаль АВС

Описать функцию, которая находит максимальную длину строк текстового файла t. Реализовать программу, определяющую длину (количество символов) в самой длинной строке произвольного текстового файла с использованием этой функции.

+4
Ответы (1)
  1. 6 октября, 18:06
    0
    Var t:text;

    max:integer;

    function Maxt (var t:text) : integer;

    var s:string;

    max:integer;

    begin;

    max:=-280;

    assign (t,'text. txt') ;

    reset (t) ;

    while not (Eof (t)) do

    begin;

    readln (t, s) ;

    if length (s) >max then

    max:=length (s) ;

    end;

    close (t) ;

    Maxt:=max;

    end;

    begin;

    max:=maxt (t) ;

    writeln ('Max:', max) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «7. Текстовый файл. Паскаль АВС Описать функцию, которая находит максимальную длину строк текстового файла t. Реализовать программу, ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дан текстовый файл с именем input. txt в первой строке которого записано натуральное число N, а во второй строке N целых чисел. Переписать в файл с именем a. dat числа, кратные 100 из исходного файла, а в файл с именем b.
Ответы (1)
Домашнее задание: 1. Запишите на языке Паскаль программу, которая для произвольного двузначного числа определяет сумму и произведение его цифр. 2.
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
1) Сколько символов в тексте, если 1) Сколько символов в тексте, если мощность алфавита-64 символа, а объем информации, содержащийся в нем-1,5 Кбайт. 2) Сообщение занимает 3 страницы по 25 строк. В каждой строке записано по 60 символов.
Ответы (1)
1. Приветствие участникам олимпиады от лунных человечков записано с помощью всех символов лунного алфавита: ЮМА_ЮМ. Сколько информации оно несет? 2. Сообщение занимает 6 страниц по 35 строк. В каждой строке записано по 50 символов.
Ответы (2)