Задать вопрос
6 июня, 00:28

Моделирование суммирующей машины Паскаля.

Дана последовательность целых чисел. Требуется определить сумму положительных и сумму отрицательных чисел.

Паскаль АВС

+2
Ответы (1)
  1. 6 июня, 00:52
    0
    Var ar:array[1 ... 5] of integer;

    i, k1, k2:integer;

    begin;

    for i:=1 to 5 do

    begin;

    readln (ar[i]) ;

    if ar[i]<0 then k1:=k1+ar[i] else k2:=k2+ar[i];

    end;

    writeln ('Сумма положительных:', k2) ;

    write ('Сумма отрицательных:', k1) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Моделирование суммирующей машины Паскаля. Дана последовательность целых чисел. Требуется определить сумму положительных и сумму ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль АВС Моделирование исполнителя "Счётчик". Дана последовательность целых чисел. Требуется определить, сколько в ней четных и нечетных чисел
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Составить программу: 1. Дана последовательность чисел. Найти количество отрицательных элементов. Последовательность целых чисел Найти сумму между максимальными и минимальным элементом последовательность 0-признак конца ведения последовательности. 2.
Ответы (1)
1. Массив и 4 целых чисел вводится с клавиатуры. Найти и вывести произведение элементов массива. 2. Массив из 6 отрицательных и положительных целых чисел вводится в области описания констант. Найти сумму положительных элементов массива. 3.
Ответы (1)
Дано массив с N положительных и отрицательных чисел. а) найти среднее аримфметичкое отдельно для положительных, среднее геометрическое - для негативных. б) найти максимальную по длинне последовательность чисел с одинаковым знаком.
Ответы (1)