Задать вопрос
1 мая, 14:28

Помогите написать Программу на Языке Программирования Паскаль, который:

1) Имеет 10 случайных элементов от 0 до 99 и выводит на экран

2) Ищет Индекс, равный 25, если такового нет, то сообщает об этом.

Премного благодарен.

+1
Ответы (1)
  1. 1 мая, 16:01
    0
    Var

    i:byte;

    a:array[1 ... 10] of byte;

    Fortune:boolean;

    begin

    Randomize;

    Write ('Элементы массива: ') ;

    Fortune:=False;

    for i:=1 to 10 do begin

    a[i]:=Random (100) ;

    Fortune:=Fortune or (a[i]=25) ;

    Write (a[i],' ')

    end;

    Writeln;

    if not Fortune then Writeln ('Нет элемента со значением 25')

    end.

    Тестовые запуски:

    Элементы массива: 86 57 51 82 5 25 20 77 67 86

    Элементы массива: 80 0 7 50 1 12 61 17 96 95

    Нет элемента со значением 25
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Помогите написать Программу на Языке Программирования Паскаль, который: 1) Имеет 10 случайных элементов от 0 до 99 и выводит на экран 2) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сравните. P. S. напишите решение а) 285 (индекс 10) и 11D (индекс 16) б) 111111 (индекс 2) и 1111 (индекс 8) в) 6 С (индекс 16) и 101001 (индекс 2) г) 55 (индекс 16) и 125 (индекс 8)
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Помогите решить задачи на паскаль. 1) Дан массив случайных чисел (количество элементов вводите с клавиатуры). Найти произведение всех элементов массива. 2) Дан массив случайных чисел (количество элементов вводите с клавиатуры).
Ответы (1)
1) напишите программу, которая спрашивает целое число n и считает сумму целых чисел, Муму чётных чисел и сумму нечётных от 1 до n 2) напишите программу, которая спрашивает целые числа а и b и выводит на экран квадраты чисел от а до b 3) напишите
Ответы (1)