Задать вопрос
23 мая, 04:24

Заполните массив случайными числами в диапазоне 0 ... 100 и подсчитайте отдельно среднее значение всех элементов, меньших 50, и среднее значение всех элементов, которые больше или равны 50.

+2
Ответы (1)
  1. 23 мая, 06:28
    0
    Вот программа:

    uses Crt;

    const n=20;

    type Vec=array [1 ... n] of integer;

    var A: Vec;

    i, Sum1, Sum2, Col1, Col2: integer;

    begin

    ClrScr;

    Randomize;

    Sum1:=0;

    Sum2:=0;

    Col1:=0;

    Col2:=0;

    WriteLn ('Massiv A : ') ;

    for i:=1 to n do

    begin

    A[i]:=random (100) ;

    Write (A[i]: 4) ;

    if A[i]<50 then

    begin

    Sum1:=Sum1+A[i];

    Col1:=Col1+1;

    end else

    begin

    Sum2:=Sum2+A[i];

    Col2:=Col2+1;

    end;

    end;

    WriteLn;

    WriteLn ('Sred<50 : ', Sum1/Col1:6:2) ;

    WriteLn ('Sred>=50 : ', Sum2/Col2:6:2) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Заполните массив случайными числами в диапазоне 0 ... 100 и подсчитайте отдельно среднее значение всех элементов, меньших 50, и среднее ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. Заполните массив случайными числами в диапазоне 20 ... 100 и подсчитайте отдельно число чётных и нечётных элементов (Программа Питон) 2. Заполните массив случайными числами в диапазоне 1000 ...
Ответы (1)
С помощью Паскаля: 1. Заполните массив случайными числами в интервале [0; 100] и подсчитайте отдельно среднее значение всех элементов, которые меньше 50, и среднее значение всех элементов, которые больше или равны 50. 2.
Ответы (1)
Решить не могу задачи по информатике: 1. Составьте программу ввода элементов массива h [1 ... 8] с клавиатуры и вывода на экран элементов с отрицательными значениями. 2. Составьте программу, которая заполняет массив h [1 ...
Ответы (1)
Решите задачи: 1) Составьте программу ввода элементов массива [1 ... 8] с клавиатуры и вывода на экран элементов массива с отрицательными значениями. 2) Составьте программу, которая заполняет массив а [1 ...
Ответы (1)
Во имя радостных мессий, помогите хоть одну задачку. Не шарю ( Дан массив из 15 элементов. Необходимо заполнить его с помощью оператора присваивания (случайными числами), вывести все элементы в строку, а затем вывести произведение всех элементов
Ответы (1)