Задать вопрос
18 июня, 06:02

Напишите решение задачи в паскале:

Прямоугольник задан координатами левого верхнего и правого нижнего углов. Найти площадь и периметр. (С помощью вспомогательного алгоритма)

+1
Ответы (1)
  1. 18 июня, 06:19
    0
    Var a, b, x1, x2, y1, y2, s, p: real;

    begin

    write ('Введите через пробел x1 и y1: ') ;

    read (x1, y1) ;

    write ('Введите через пробел x2 и y2: ') ;

    read (x2, y2) ;

    a:=x2-x1;

    b:=y1-y2;

    s:=a*b;

    p:=2 * (a+b) ;

    writeln ('S = ', s) ;

    writeln ('P = ', p) ;

    end.

    Делать подобное контрпродуктивно, слишком много ненужного кода.

    var x1, x2, y1, y2, s, p: real;

    function a (x1, x2: real) : real;

    begin

    a:=x2-x1;

    end;

    function b (y1, y2: real) : real;

    begin

    b:=y1-y2;

    end;

    begin

    write ('Введите через пробел x1 и y1: ') ;

    read (x1, y1) ;

    write ('Введите через пробел x2 и y2: ') ;

    read (x2, y2) ;

    s:=a (x1, x2) * b (y1, y2) ;

    p:=2 * (a (x1, x2) + b (y1, y2)) ;

    writeln ('S = ', s) ;

    writeln ('P = ', p) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите решение задачи в паскале: Прямоугольник задан координатами левого верхнего и правого нижнего углов. Найти площадь и периметр. (С ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1) приведите пример исполнителя алгоритма. 2) Должен ли составитель алгоритма знать, кто будет являться исполнителем алгоритма? 3) Перечислите свойства алгоритма. 4) Поясните значение свойства алгоритма "определенность".
Ответы (1)
Формальное исполнение алгоритма - это? Выберите один ответ: A. Разбиение алгоритма на конкретное число команд и их пошаговое исполнение B. Исполнение алгоритма конкретным исполненителем с полной записью его рассуждений C.
Ответы (1)
1) Задан массив из 11 целых чисел. Найти сумму элементов массива, кратных 5 2) Задан массив из 11 целых чисел. Посчитать количество нечётных элементов массива. 3) задан массив из 9 целых чисел. Вывести на экран чётные элементы
Ответы (1)
Два игрока играют в игру. На координатной плоскости стоит фишка. Игроки ходят поочереди. В начале игры фишка находится в точке с координатами (4,2).
Ответы (1)
Помогите! Информатика 1 Укажите неправильные высказывания. А) Массовость алгоритма заключается в том, что обеспечивается решение не одной конкретной задачи, а некоторого класса задач данного типа Б) Детерминируемость алгоритма заключается в том, что
Ответы (1)