Задать вопрос
3 октября, 02:44

Вывести на экран все двузначные числа, сумма цифр которых равна заданному числу n.

Написать программу в паскаль abc

+2
Ответы (1)
  1. 3 октября, 05:47
    0
    Var

    i, j:0 ... 9;

    n: integer;

    begin

    readln (n) ;

    for i:=1 to 9 do

    for j:=0 to 9 do

    if i+j=n then writeln (i*10+j)

    end.

    6

    15

    24

    33

    42

    51

    60
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Вывести на экран все двузначные числа, сумма цифр которых равна заданному числу n. Написать программу в паскаль abc ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
По заданному числу K (от 0 до 10) вывести его название. Например при K=2 вывести на экран , при K=3 вывести на экран и т. д
Ответы (1)