Задать вопрос
16 сентября, 19:37

1. В 6 школ города поступили компьютеры. В первую только один, во вторую - 4, в третью - 9 и т. д. Подсчитайте общее количество компьютеров. Выведите на экран номер школы, где количество компьютеров кратно 4.

2. Сестра братишки-шалунишки в октябре ежедневно записывает показания температур в дневник наблюдений. Однажды братишка-шалунишка сделал в записях температур небольшие исправления, дописав к отрицательной температуре справа ноль, к положительной добавил знак минус, а перед нулем приписал 5. Что увидит сестренка после исправлений. Вывести исходные и полученные данные.

+1
Ответы (1)
  1. 16 сентября, 20:04
    0
    Первая программа может выглядеть так:

    uses Crt;

    const n = 6;

    Type Mas = array [1 ... n] of integer;

    var A: Mas;

    i, Sum : integer;

    begin

    ClrScr;

    Sum: = 0;

    for i:=1 to n do

    begin

    A[i]:=i*i;

    Sum:=Sum+A[i];

    end;

    for i:=1 to n do

    if (A[i] mod 4=0) then WriteLn (' Номер школы: : ', i) ;

    Writeln (' Количество компьютеров: ', Sum) ;

    ReadLn;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «1. В 6 школ города поступили компьютеры. В первую только один, во вторую - 4, в третью - 9 и т. д. Подсчитайте общее количество ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
1. for + random a. вывести случайное количество случайных чисел b. вывести на экран 10 случайных чисел c. вывести на экран 10 случайных чисел, значение которых лежит в отрезке [0,10] d.
Ответы (1)
1) Заполнить массив размером N целыми числами последовательно от 1 до N. Вывести его на экран. Найти сумму элементов массива и вывести ее на экран. 2) Заполнить массив размером N целыми числами последовательно от N до 1. Вывести его на экран.
Ответы (1)
Паскаль. 1. вывести на экран все четные числа от 1 до n. 2. вывести на экран все трехзначные числа. 3. вывести на экран четырехзначные числа оканчивающийся на 7. 4. вывести на экран все трехзначные и двухзначные числа сумма цифр которых равна девяти.
Ответы (1)
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
1. В языке PHP создайте генератор случайного числа от 1 до 10. Выведите результат выполнения на экран любым способом. 2. Если полученное случайное число четное, выведите на экран слово "четное", иначе выведите на экран слово "нечетное". 3.
Ответы (1)