Задать вопрос
15 сентября, 20:38

Написать программу, состоящую из 30 чисел, числа понимают значения от - 500 до 500, программа находит минимальное значение среди нечетных элементов массива, которые кратны 5.

+5
Ответы (1)
  1. 15 сентября, 22:50
    0
    Const

    n = 30;

    var

    x: array[1 ... n] of integer;

    i, t, min: integer;

    begin

    Randomize;

    Writeln ('Элементы массива') ;

    min:=32767;

    for i : = 1 to n do

    begin

    t : = Random (1001) - 500;

    x[i] : = t;

    Write (t:5) ;

    if Odd (i) and (t mod 5 = 0) and (min>t) then min:=t

    end;

    Writeln;

    Writeln ('Минимальный нечетный элемент, кратный 5, равен ', min)

    end.

    Тестовое решение:

    Элементы массива

    -64 438 - 290 358 - 424 234 - 444 - 17 171 - 57 - 373 - 279 242 - 403 - 262 34 - 488 365 341 - 468 163 - 276 193 - 140 126 - 466 - 236 - 34 350 - 369

    Минимальный нечетный элемент, кратный 5, равен - 290
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу, состоящую из 30 чисел, числа понимают значения от - 500 до 500, программа находит минимальное значение среди нечетных ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите программу, которая фармирует масси из N элементов (максимальное количество элементов равно 20), значения элементов массива - случайные числа от - 10 до 25 Программа должна: 1) выводить на экран сначала все элементы массива, стоящие на
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Написать программу которая формирует массив из n элементов (максимальное количество элементов равно 20), значения элементов массива случайные целые числа от - 10 до 25.
Ответы (1)
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Составить программу вывода на экран в первую строку 5 элементов массива, а во вторую - остальные 5 элементов массива; 2. Составить программу вывода элементов массива в обратном порядке; 3.
Ответы (1)