Задать вопрос
11 июля, 12:26

Составить программу обмена значениями трех переменных величин: a, b, c. на языке Pascal

+4
Ответы (1)
  1. 11 июля, 16:26
    0
    Var

    A, B, C, D:integer;

    Begin

    Write ('a = ') ; Read (a) ;

    Write ('b = ') ; Read (b) ;

    Write ('c = ') ; Read (c) ;

    d:=a;

    a:=b;

    b:=c;

    c:=d;

    WriteLn;

    WriteLn ('a = ', a) ;

    WriteLn ('b = ', b) ;

    WriteLn ('c = ', c) ;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить программу обмена значениями трех переменных величин: a, b, c. на языке Pascal ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Запишите программу циклического обмена значениями трех переменных a, b, c. Схема циклического обмена:a->b->c. Например если до обмена было:a=1, b=2, c=3, то после обмена должно стать:a=3, b=1, c=2. Выполнить трассировку
Ответы (1)
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
4. Запишите на языке Паскаль программу циклического обмена значениями трёх переменных a, b, c. Например, если до обмена было: a=1, b=2, c=3, то после обмена должно стать: a=2, b=3, c=1.
Ответы (1)
Что осуществляется с помощью этих трех действий: a=a+b b=a-b a=a-b a) нахождение суммы и разности двух переменных б) нахождение среднеарифметического двух переменных в) обмен значениями двух переменных г) нахождение максимального значения двух
Ответы (1)
Ребят, помогите, а?) Запишите алгоритм циклического обмена значениями трёх переменных a, b, c. Схема циклического обмена: a-› b-› c (цикл. От "с" снова к "а").
Ответы (1)