Задать вопрос
3 мая, 08:31

Дано слово. Если его длина нечётная, то удалить среднюю букву, в противном случае - две буквы

+3
Ответы (1)
  1. 3 мая, 11:22
    0
    Program programma;

    uses crt;

    var s, rez: string;

    L: integer;

    Begin clrscr;

    write ('Введите слово: ') ;

    readln (s) ;

    l: = length (s) ;

    if l mod 2 = 1 then

    rez: = copy (s, 1, (l div 2)) + copy (s, ((l div 2) + 2), (l div 2))

    else

    rez: = copy (s, 1, (l div 2) - 1) + copy (s, ((l div 2) + 2), (l div 2)) ;

    writeln (rez) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Дано слово. Если его длина нечётная, то удалить среднюю букву, в противном случае - две буквы ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Дано число. Если оно делится на 11, то уменьшить ч Дано число. Если оно делится на 11, то уменьшить число в 11 раз, в противном случае уменьшить число на 11. исло в 11 раз, в противном случае уменьшить число на 11.
Ответы (1)
По горизонтали: 1. Объект Windows (4, буквы) 2. А4 - это ... (6, буквы) 3. Есть у человека и компьютера. (6, буквы) 4. Начни работу с этой кнопки ... (4, буквы) 5. Чтобы работать с объектом, его надо ... (8, буквы) 6. Есть в ресторане и компьютере.
Ответы (1)
Составить процедуру, вычисляющую значение True, если все элементы одномерного массива имеют значения, большие заданной величины, и False в противном случае.
Ответы (1)
Написать простую программу (паскаль) Дано три числа a, b, c. В случае четности одного из них на экран выводится "Хотя бы одно из них четно" в противном случае "Ни одного четного".
Ответы (1)
Составьте программу которая позволяет удалить слово t из строки s. Строка s и слово t, которое надо удалить, вводятся с клавиатуры
Ответы (1)