Задать вопрос
7 февраля, 08:19

Какой текст будет выведен на экран в результате выполнения следующего фрагмента программы?

s:='Example'; s0:='ABC';

Delete (s, 1,3) ;

writeln (s) ;

+5
Ответы (1)
  1. 7 февраля, 09:34
    0
    Delete (процедура) у даляет подстроку из строки.

    В твоем случае delete (s, i, k)

    s-исходная строка,

    i - с какой позиции

    k - сколько символов удалять.

    Форма записи Delete (s, 1,3) означает из строки s, убрать с первого по третий символ (строку с первого элемента по третий).

    writeln (s) = > ' mple'

    P. S.: s0:='ABC'; - это действительно лишнее :)
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Какой текст будет выведен на экран в результате выполнения следующего фрагмента программы? s:='Example'; s0:='ABC'; Delete (s, 1,3) ; ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Сделать так чтобы Writeln был заменен другим словом и повторялься не больше двух раз program choise; var N_M:integer; writeln (' введи номер месяца ') ; readln (N_M) ; case N_M of 1:writeln (' январь ') ; 2:writeln (' февраль ') ;
Ответы (1)
3. Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 2 do begin a:=a+i; end; Ответ: введите число 4.
Ответы (2)
1) Определите значение целочисленных переменных a и b после выполнения фрагмента программы: a : = 3 + 8*4; b : = (a div 10) + 14; a : = (b mod 10) + 2;
Ответы (1)
Что выведется на экран в результате выполнения фрагмента программы: s:=0; FOR j: = 1 TO 3 DO s:=s+2*j; write (' j=', j, ' s=', s) Что выведется на экран в результате выполнения фрагмента программы: p:=1; FOR k:=1 TO 5 DO begin p:=p*k; end;
Ответы (1)
Имеется условный оператор:if D10 then writeln ('ура!') else writeln ('плохо ...') ; Какими операторами его можно заменить? Выберите несколько из 4 вариантов ответа: 1) if D=10 then writeln ('ура!') else writeln ('плохо ...
Ответы (1)