Задать вопрос
25 октября, 09:49

Нужно решить через Паскаль с помощью циклов for или while

1) Известно количество пассажиров за каждый месяц. Вычислить ср. арифметическое за год

2) Известно кол-во очков каждого игрока команды. Определить лучшего.

+2
Ответы (1)
  1. 25 октября, 13:35
    0
    1) var s, i, a:integer;

    begin

    s:=0;

    for i:=1 to 12 do

    begin

    read (a) ;

    s:=s+a;

    end;

    writeln (s/12:0:2)

    end.

    2) var i, a, max, n:integer;

    begin

    max:=-maxint;

    readln (n) ; {ввод кол-ва игроков в команде}

    for i:=1 to n do

    begin

    read (a) ;

    if a>max then max:=a;

    end;

    writeln (max)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужно решить через Паскаль с помощью циклов for или while 1) Известно количество пассажиров за каждый месяц. Вычислить ср. арифметическое ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
поставьте знаки арифметических операций в каждой схеме. А) скорость? время=путь б) путь? время=скорость в) масса 1 батона? количество батонов=общ. масса г) кол. батонов? кол. буханок=общ. кол. д) кол. конфет в 1 коробке? кол. коробок = общ. кол.
Ответы (1)
Какие события произошли в указанные даты? 1) 1946 год - 2) 1842 год - 3) 1880 год - 4) 1951 год - 5) 1876 год - 6) 1969 год - 7) 80-е годы XX века - 8) 1963 год - в Америке изобретен телефон в США начала функционировать первая в мире компьютерная
Ответы (1)
Год создания первого компьютера, год создания первого отечественного компьютера, год открытия радиосвязи, год первого полета человека, год принятия христианства на руси, год первого упоминания в летописи о москве, год начала великой отечественной
Ответы (1)
Два игрока играют в следующую игру. перед ними лежат три кучки камней, в первый 2 камня, во второй - 3, в третьей - 4. у каждого игрока неограниченное кол-во камней. игроки ходят по очереди.
Ответы (1)