Задать вопрос
27 апреля, 09:02

Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных (провереть кратность 7 командой mod введя условие если в цикл)

+4
Ответы (2)
  1. 27 апреля, 10:19
    0
    Var

    x, i, y:integer;

    begin

    for i:=1 to 1000 do

    begin

    x: = i mod 7;

    if x=0 then

    begin

    y:=y+1;

    writeln (i) ; / / строка выводит все числа кратные семи. она подлежит удалению

    end;

    end;

    writeln (y) ;

    end.
  2. 27 апреля, 10:42
    0
    Var

    count, i:integer;

    begin

    i:=0; count:=0;

    repeat

    i:=i+2;

    if i mod 7 = 0 then count:=count+1;

    until i>=1000;

    writeln (count) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для решение задачи - посчитать количество чисел от 1 до 1000 кратных 7 и честных (провереть кратность 7 командой mod ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы