Задать вопрос
24 июля, 14:20

Клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение "Неверное число".

+5
Ответы (1)
  1. 24 июля, 15:35
    0
    Var chislo, x, i, s: integer;

    begin

    writeln ('Введите число:') ;

    readln (chislo) ;

    x : = chislo;

    s : = 0;

    if (chislo 999) then writeln ('Неверное число!')

    else begin

    while (x 0) do begin

    s : = s + (x mod 10) ;

    x : = x div 10;

    end;

    if s mod 2 = 0 then write ('Да')

    else write ('Нет') ;

    end;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
С клавиатуры вводится трёхзначное число. Нужно вывести ответ "Да", если все его цифры четные, и ответ "Нет" в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение "Неверное число".
Ответы (1)
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
1. Пользователем вводится целое число. Вывести на экран последовательность целых чисел от единицы до этого числа. 2. Вывести на экран 10 строк, содержащие символ *, причем количество * в каждой строке должно быть равно номеру строки. 3.
Ответы (1)
Напишите программу, которая принимает с клавиатуры числа, пока не будет введено значение 999. Программа должна подсчитать, сколько значений было введено с клавиатуры (не считая значения 999) и вывести эту информацию на экран.
Ответы (1)