Задать вопрос
15 мая, 03:40

13. Для какого значения числа Z высказывание ((Z > 2) Ú (Z > 4)) → (Z > 3) будет ложным?

14. Определите значение переменной c после выполнения следующего фрагмента программы, в котором a, b и c - переменные целочисленного типа:

a : = 27;

b : = 13;

if b div 5 > 2

then

c : = b mod 5 + a mod 3

else

c : = (b + a) mod 6;

15. Определите, что будет напечатано в результате работы следующего фрагмента программы?

var n, s, d: integer;

begin

readln (d) ;

n : = 3;

s : = 57;

for i: = 2 to 5 do begin

s : = s + n;

n : = n + 4

end;

write (s)

end.

+3
Ответы (1)
  1. 15 мая, 04:25
    0
    13. Для z = 3;

    14 т. к b div 5 = 2

    c : = (b + a) mod 6;

    c: = 40 mod 6

    c: = 4

    15. Ничего не будет напечатано, т. к программа не будет работать:

    Паскаль будет ругаться, что не объявлен идентификатор i.

    Но если бы он был, то на экран бы выводилось число 93
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «13. Для какого значения числа Z высказывание ((Z > 2) Ú (Z > 4)) → (Z > 3) будет ложным? 14. Определите значение переменной c после ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Определить значение выражения: 1) 10 div 15 2) 10 div 2 3) 10 mod 2 4) 10 mod 17 5) 123 mod 10 6) 123 div 10 7) 1 div 2 8) 123 mod 1000 9) 100 mod 27 div 3 10) 100 div 5 mod 3 11) 98725 div 1000 mod 10 12) 100 mod 5 div 3
Ответы (1)
6) Определите, что будет напечатано в результате работы следующего фрагмента программы: var n, s: integer; begin s : = 0; for n:=4 to 13 do begin s : = s + 15; end; write (s) end.
Ответы (1)
Какое число будет напечатано в результате выполнения программы: var i, k: integer; function f (x: integer) : integer; var m: integer; begin if x < 10 then f : = x else begin m : = f (x div 10) ; if m < x mod 10 then f : = x mod 10 else f : = m; end;
Ответы (1)
Тест: Операторы целочисленной арифметики div и mod 1. Вычислите: 25 div 11 2.27 3 2 2. Вычислите: 64 div 9 1 7 6 3. Вычислите: (35 div 2) div 5 2 17 3 4. Вычислите: (78 div 5) mod 10 5 15 10 5. Вычислите: (25 mod 11) + (18 mod 7) 3 7 4 6.
Ответы (1)
1. Решите примеры 13 div 5 = 13 mod 5 = 5 div 5 = 5 mod 5 = 3 div 8 = 3 mod 8 = 10 div 6 mod 3 = 2. Определите результат выполнения следующих действий а) a:=1819; b: = (div (а, 100)) * 10 + 9 a: = mod (10*b - a),100) а = ? b = ?
Ответы (1)