Задать вопрос
16 августа, 21:25

Напишите процедуру, которая выводит на экран запись числа меньшего, чем 8^10 в виде 10 знаков в восьмеричной системе счисления.

+1
Ответы (1)
  1. 17 августа, 01:02
    0
    Procedure Dec2Oct (n:longint) ;

    { Перевод натурального десятичного n в восьмеричную систему счисления

    и вывод результата }

    const

    alpha = '01234567';

    var

    s: string;

    i:integer;

    begin

    s : = '';

    while n > 0 do begin

    s : = alpha[ (n mod 8) + 1] + s;

    n : = n div 8

    end;

    for i:=Length (s) to 9 do s:='0'+s;

    Write (s)

    end;

    { Использование }

    var

    x:longint;

    begin

    Write ('Введите десятичное число: ') ; Read (x) ;

    Write ('В восьмеричной системе счисления: ') ;

    Dec2Oct (x) ;

    Writeln

    end.

    Тестовое решение:

    Введите десятичное число: 1234567

    В восьмеричной системе счисления: 0004553207
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите процедуру, которая выводит на экран запись числа меньшего, чем 8^10 в виде 10 знаков в восьмеричной системе счисления. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
А) 1000001110 в двоичной системе счисления+1100110 в двоичной системе счисления б) 10001001 в двоичной системе счисления-1010101 в двоичной системе счисления в) 45 в восьмеричной системе счисления * 71 в восьмеричной системе счисления г) 1AF1 в
Ответы (1)
1) Десятичное число 4563 в двоичной системе счисления равно 2) Десятичное число 800 в восьмеричной системе счисления равно 3) Десятичное число 781 в шестнадцатеричной системе счисления равно 4) Двоичное число 1000000 в десятичной системе счисления
Ответы (1)
1) Напишите программу, которая строит "квадрат" из знаков '*' заданного размера. Используйте процедуру. 2) Напишите программу, которая выводит в столбик цифры введённого числа, начиная с последней. Используйте процедуру.
Ответы (1)
1. Запишите число 156 в шестнадцатеричной системе счисления. 2. Запишите число AD16 В десятичной системе счисления. 3. Запишите число 111100000012 в шестнадцатеричной системе счисления. 4. Запишите число 125 В 16 В двоичной системе счисления. 5.
Ответы (1)
Выполните сложение: а) 1153 в 8 системе счисления + 1147 в 8 системе счисления. б) 4DFв 16 системе счисления + 160 в 16 системе счисления. в) 1110101010 в 2 системе счисления + 10111001 в 2 системе счисления.
Ответы (1)