Задать вопрос
17 июня, 20:59

Напишите рекурсивную функцию, возводящую число a в степень n. Гарантируется, что все числа "помещаются" в стандартные вещественные (a и ответ) и целые (n) типы.

Входные данные

Вводится 2 числа - a и n (число n может быть отрицательным).

Выходные данные

Необходимо вывести значение an

Примеры

входные данные

2 - 1

выходные данные

0.5

+3
Ответы (1)
  1. 18 июня, 00:46
    0
    Var a, f: real; n, i, g: integer; begin read (a, n) ; if n<0 then begin g:=n; n:=-n; end; f:=1; for i:=1 to n do f:=a*f; if g<0 then write (1/f) else write (f) ; readln; readln end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Напишите рекурсивную функцию, возводящую число a в степень n. Гарантируется, что все числа "помещаются" в стандартные вещественные (a и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Помогите решить! 1))) Вводятся 4 числа: a, b, c и d. Выведите все числа на отрезке от a до b, дающие остаток c при делении на d Входные данные 1 4 1 2 выходные данные 1 3 Входные данный 1 5 0 4 выходные данные 4 2))) Выведите все числа на отрезке от
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Входные данные Вводится натуральное число N, которое не превосходит 30. Выходные данные Вычислите 1+2+22+23+ ...+2 N. Примеры входные данные 1 выходные данные 3 входные данные 4 выходные данные 31
Ответы (1)
Выведите все натуральные делители числа x в порядке возрастания (включая 1 и само число). Входные данные Вводится натуральное число x Выходные данные Выведите все делители числа x Примеры входные данные 7 выходные данные 1 7 входные данные 21
Ответы (1)
Написать на Паскале Четные числа Входные данные Вводятся целые числа a и b. Гарантируется, что a не превосходит b Выходные данные Выведите (через пробел) все четные числа от a до b (включительно). входные данные 2 5 выходные данные 2 4
Ответы (1)