Задать вопрос
22 февраля, 17:56

Составить подпрограмму, определяющую в строке % цифр.

+5
Ответы (1)
  1. 22 февраля, 19:03
    0
    Процент цифр можно найти, как процентное отношение количества цифр к длине строки, но при этом будут учитываться и пробелы. Если в строке есть символы, которые учитывать не надо, следует подсчитать количество таких символов и предварительно вычесть его из длины строки. В приведенной ниже программе для простоты считается, что учитываться должны все символы.

    const

    digits=['0' ... '9'];

    var

    i, k, n:integer;

    p:real;

    s:string;

    begin

    Writeln ('Введите строку') ;

    Readln (s) ;

    n:=Length (s) ; k:=0;

    for i:=1 to n do

    if s[i] in digits then Inc (k) ;

    p:=100*k/n;

    Writeln ('Процент цифр в строке равен ', p:0:2)

    end.

    Тестовое решение:

    Введите строку

    Самым большим водопадом в мире считается Анхель (Венесуэла), его высота 979 м. Открыт в 1933 г. летчиком Джеймсом Анхель.

    Процент цифр в строке равен 5.88
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Составить подпрограмму, определяющую в строке % цифр. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Нужно сделать подпрограмму. Помогите не умею я подпрограммы писать! 9 класс, Делфи Сделать подпрограмму, которая вводит с клавиатуры 3 числа, находит найбольшее и выводит на экран.
Ответы (1)
Разработать подпрограмму, которая в качестве аргумента получает целое число и проверяет, является ли оно простым. Используя подпрограмму вывести на экран все простые числа из промежутка целых чисел, определенного пользователем. Pascal ABC
Ответы (1)
Написать подпрограмму для поиска максимального из всех двухзначных чисел в строке. Если в строке нет ни одного двухзначного числа, то подпрограмма должна вернуть 0. function CalcMax (s:string) : integer; с процедурой val
Ответы (1)
Помогите информатика 8 класс Задача 1. Составить программу определяющую длину фамилии и имени. Задача 2. Даны два слова. Составить программу определяющую произведение данных слов. Задача 3.
Ответы (1)
Размер окна текстового редактора - 20 строк по 64 символа в строке. Курсор находится в левом верхнем углу экрана и указывает на символ, стоящий в 25 - й строке и 5 - й позиции текста.
Ответы (1)