Задать вопрос
12 сентября, 23:06

Написать программу для Паскаль через оператор Case.

Для целого числа K от 1 до 99 напечаать фразу "мне K лет", учитывая при этом что при вводе некоторых значений K слово "лет" надо заменить на слово "год" или "года".

+5
Ответы (1)
  1. 12 сентября, 23:28
    0
    Program p1;

    Var a:integer;

    Begin

    Write ('Введите возраст: ') ;

    Readln (a) ;

    Case a of

    11 ... 14:Write ('Мне ', a,' лет') ;

    else

    Case a mod 10 of

    1:Write ('Мне ', a,' год') ;

    2 ... 4:Write ('Мне ', a,' года') ;

    else Write ('Мне ', a,' лет') ;

    End;

    End;

    End.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу для Паскаль через оператор Case. Для целого числа K от 1 до 99 напечаать фразу "мне K лет", учитывая при этом что при ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Для целого числа K от 1 до 99 напечатать фразу "Мне k лет", учитывая при этом, что при некоторых значениях K слово "лет" надо заменить на слово "год" или "года". Например, 11 лет, 22 года, 51 год.
Ответы (1)
Решить с помощью Borland C Для целого числа k от 1 до 99 напечатать фразу "Мне k лет", учитывая при этом, что при некоторых значениях k слово "лет" надо заменить на слово "год" или "года". Например, 11 лет, 22 года, 51 год.
Ответы (1)
10. Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Составить программу, осуществляющую ввод числовых переменных. При вводе положительного числа вывести информацию: "Число больше ноля", при вводе отрицательного числа - "Число меньше ноля", при вводе ноля - "Вы ввели ноль".
Ответы (1)
Написать программу. Для целого числа K от 1 до 99 напечатать фразу: "Мне K лет, учитывая, что может быть год, лет, года. Год: 1, 21, 31, 41 ... (n mod 10=1). Лет: 5-20, 25-30, 35-40, 45-50 ... (n mod 10=0, 5, 6, 7, 8, 9).
Ответы (1)