Задать вопрос
16 ноября, 22:32

Нужна программа для Паскаля - Реверс массива.

+4
Ответы (1)
  1. 16 ноября, 23:32
    0
    Var

    mas:array[1 ... 1000] of integer;

    N, i, c:integer;

    begin

    readln (N) ;

    for i:=1 to N do

    readln (mas[i]) ;

    for i:=1 to (N div 2) do

    begin

    c:=mas[i];

    mas[i]:=mas[N-i+1];

    mas[N-i+1]:=c;

    end;

    for i:=1 to N do

    write (mas[i],' ') ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Нужна программа для Паскаля - Реверс массива. ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
В записи m[7]=9 m обозначает 1) имя массива 2) имя элемента массива 3) номер элемента массива 4) значение элемента массива в записи m[7]=
Ответы (1)
1. Возвести в квадрат все элементы массива A. Размер массива и значения элементов массива - произвольные. 2. Увеличить на 4 все элементы в первой половине массива A (считать, что в массиве чётное число элементов).
Ответы (1)
Помогите с информатикой 1. Что такое массив? 2. Что такое элемент массива? 3. Что такое индекс массива? 4. Что такое размерность массива? 5. Зачем нужны массивы? 6. Как можно обратиться к ячейке массива? 7. Какого типа могут быль элементы массива? 8.
Ответы (1)
Уровень C. Напишите программу, которая заполняет массив из N = 10 случайными числами в диапазоне [10,50], выводит его на экран, а затем выполняет реверс отдельно первой и второй половин массива.
Ответы (1)
1) Найти сумму отрицательных элементов массива целых чисел. Размерность массива 10. Заполнение массива осуществить случайными числами от - 20 до 20. 2) Найдите сумму чётных элементов массива целых чисел. Размерность массива 20.
Ответы (1)