Задать вопрос
20 января, 06:45

Определите количество последовательностей из нулей и единиц длины N (длина - это общее количество нулей и едииниц), в которых никакие три единицы не стоят рядом.

Вводится натуральное число N, не превосходящее 40.

+4
Ответы (1)
  1. 20 января, 09:46
    0
    Описание алгоритма:

    Будем наращивать длину последовательности от 0 знаков до N. Пусть после какого-то количества шагов у нас выписаны все последовательности длины А и мы хотим узнать количество подходящих последовательностей длины А+1. Распределим все последовательности на три группы (так как предыдущие символы нас не волнуют, то любые последовательности одной группы для нас равнозначны) :

    1) Заканчиваются на 0.

    2) Ровно на одну единицу

    3) Ровно на две единицы.

    Из каждой последовательности группы 1 приписыванием нуля или единицы мы можем получить одну последовательность группы 1 и одну - группы 2. Неважно, какие именно, но они не перекрываются, т. к. предыдущие символы различны, хоть мы их и не учитываем. Точно так же из второй группы мы получаем одну последовательность группы 3 и одну группы 1, а из группы 3 - только группу 1. Таким образом, если количества последовательностей длины А по группам были (x, y, z), то для длины А+1 такое распределение будет (x+y+z, x, y). Если взять для длины 0 тройку (0, 0, 1) и просчитать тройки от 1 до N, получится искомое количество. Для N=1 и N=2 также работает правильно.

    Программа на Pascal:

    var num00, num01, num11, mem00:integer;

    n, i:byte;

    begin

    readln (n) ;

    num00:=1;

    for i:=1 to n do begin

    mem00:=num11;

    num11:=num01;

    num01:=num00;

    num00:=num01+num11+mem00;

    end;

    writeln (num11+num01+num00) ;

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Определите количество последовательностей из нулей и единиц длины N (длина - это общее количество нулей и едииниц), в которых никакие три ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Напишите задачи в Паскале задача1 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ... 1000000] Вывести на экран их произведение.} задача2 {вводится целое число n от [0 ... 200]. Затеи вводится n целых чисел от [0 ...
Ответы (2)
Помогите решить 3. С клавиатуры вводится четырехзначное число. Получить число, равное произведению его цифр. 4. С клавиатуры вводится натуральное число п. Узнайте в нем количество цифр. 5. С клавиатуры вводится натуральное число п.
Ответы (1)
Дан массив с1, с2, ..., с15, состоящий из нулей и единиц. Подсчитать количество нулей, количество единиц и количество нулей до первой единицы. Это в паскале
Ответы (1)
помогите решить три номера! 1. Вычислите сумму данных 100 натуральных чисел. Вводятся 100 чисел, сумму которых необходимо посчитать. 2. Вводится число N, а затем N чисел. Подсчитайте, сколько среди данных N чисел нулей. 3.
Ответы (1)
Найдите максимальное простое число, не превосходящее 100, представимое в виде суммы последовательных простых чисел. Например, максимальное такое число, не превосходящее 12, равно 5 (2 + 3). В ответе укажите одно целое число.
Ответы (1)