Задать вопрос
15 декабря, 16:27

Программа в паскаль АВС определите вид треугольника по известным углам при этом если сумма углов не равна 180 градусов, то программа должна сообщить, что введены некорректные данные, проверьте условие

+4
Ответы (1)
  1. 15 декабря, 19:04
    0
    Var a, b, c:real;

    begin

    writeln ('введите значения трех углов:') ;

    readln (a, b, c) ;

    if (a+b+c) 180 then writeln ('введены некорректные данные') else

    if (a=90) or (b=90) or (c=90) then writeln ('прямоугольный') else

    if (a=b) and (b=c) then writeln ('равносторонний') else

    if (a=b) or (b=c) or (a=c) then writeln ('равнобедренный') else

    writeln ('разносторонний')

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Программа в паскаль АВС определите вид треугольника по известным углам при этом если сумма углов не равна 180 градусов, то программа должна ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
Помгите! Программа Паскаль Вопрос 1. Функция служебного слова Var. Вопрос 2. С какими числами можно работать в программе Паскаль? Вопрос 3. Оператор ввода. Как он записывается в Паскаль? Вопрос 4. Функция служебного слова Const. Вопрос 5.
Ответы (1)
Дано три числа. Упорядочите их в порядке неубывания. Программа должна считывать три числа a, b, c, затем программа должна менять их значения так, чтобы стали выполнены условия a < = b < = c, затем программа выводит тройку a, b, c.
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
В Python С клавиатуры вводится натуральное число. Программа должна вывести следующее за ним четное число. Например, если ввести 7, то программа должна вывести 8, а если ввести 8, то программа должна вывести 10.
Ответы (1)