Задать вопрос
1 июля, 22:32

Написать программу обмена переменных x и y, без использования дополнительных велечин,

(это надо делать в Pascal)

+4
Ответы (1)
  1. 1 июля, 23:22
    0
    Var

    a, b:integer;

    begin

    a:=50; b:=-20; { начальное присванивание }

    Writeln ('Исходные значения: a=', a,', b=', b) ;

    a:=a+b; b:=a-b; a:=a-b;

    Writeln ('Обмен после "арифметического" способа: a=', a,', b=', b) ;

    a:=50; b:=-20; { начальное присванивание }

    a:=a xor b; b:=a xor b; a:=a xor b;

    Writeln ('Обмен после "логического" способа: a=', a,', b=', b)

    end.

    Результат выполнения программы:

    Исходные значения: a=50, b=-20

    Обмен после "арифметического" способа: a=-20, b=50

    Обмен после "логического" способа: a=-20, b=50
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Написать программу обмена переменных x и y, без использования дополнительных велечин, (это надо делать в Pascal) ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Как описывают переменные в Pascal? Какие стандартные числовые типы языка Pascal вам известны? Что вам известно о соответствии типов переменных в языке Pascal? Какие арифметические операции можно выполнять в Pascal?
Ответы (1)
3. Не используя функцию возведения в квадрат, напишите на языке Паскаль наиболее короткие алгоритмы вычисления а) y=x¹° б) y=x¹⁵ или а) y=x^10 б) y=x^15 Постараться использовать минимальное количество дополнительных переменных. 4.
Ответы (1)
Запишите программу циклического обмена значениями трех переменных a, b, c. Схема циклического обмена:a->b->c. Например если до обмена было:a=1, b=2, c=3, то после обмена должно стать:a=3, b=1, c=2. Выполнить трассировку
Ответы (1)
Вычислить произведение четырех натур. чисел, используя только операцию сложения. (Язык пр:pascal) 1) Написать программу (обычную) 2) Написать программу с использованием процедуры 3) Написать программу с исп. функции 4) Написать программу с исп.
Ответы (1)
1) Вычислить длину окружности и площадь круга одного и того же заданного радиуса R. Pascal (желательно с блок-схемой) 2) Найти сумму членов арифметической прогрессии, если известны её первый член, знаменатель и число членов прогрессии Pascal
Ответы (1)