Задать вопрос
26 июля, 13:13

Решить задачу на языке программирования Паскаль по теме "Записи":

1) Создать список песен (запись), содержащий название, стиль и длительность песен. Типы данных должны быть следующие:

1. Название - строка

2. Стиль - строка

3. Длительность песен - вещественное число

При помощи оператора присоединения внести данные в запись с клавиатуры.

+2
Ответы (2)
  1. 26 июля, 13:31
    0
    Type

    mus = record

    Name:string;

    style:string;

    dur:real;

    end;

    var

    A:array[1 ... 10000] of mus;

    i, n:integer;

    Nam, st:string;

    duration:real;

    begin

    Writeln ('Введите количество композиций: ') ;

    Readln (n) ;

    for i:=1 to n do

    begin

    Write ('Название: ') ;

    read (Nam) ;

    Write (' Стиль: ') ;

    read (ST) ;

    Write (' Длительность: ') ;

    read (duration) ;

    A[i]. Name:=Nam;

    A[i]. style:=st;

    A[i]. dur:=duration;

    end;

    end.
  2. 26 июля, 16:20
    0
    Текст приведенной ниже программы организует ввод данных и запись их в типизированный файл. Для завершения ввода в качестве названия надо ввести символ "звездочка" (*).

    type

    song=record

    name, style:string[20];

    duration:real

    end;

    var

    f:file of song;

    r:song;

    begin

    Assign (f,'MySongs. dat') ;

    Rewrite (f) ;

    Writeln ('Вводите данные в порядке "наименование, стиль, длительность') ;

    Writeln ('Для окончания ввода укажите символ * вместо наименования') ;

    repeat

    Readln (r. name) ;

    if r. name'*' then begin

    Readln (r. style) ;

    Readln (r. duration) ;

    Write (f, r)

    end

    until r. name='*';

    Close (f)

    end.
Знаете ответ?
Сомневаетесь в ответе?
Найдите правильный ответ на вопрос ✅ «Решить задачу на языке программирования Паскаль по теме "Записи": 1) Создать список песен (запись), содержащий название, стиль и ...» по предмету 📘 Информатика, а если вы сомневаетесь в правильности ответов или ответ отсутствует, то попробуйте воспользоваться умным поиском на сайте и найти ответы на похожие вопросы.
Смотреть другие ответы
Похожие вопросы по информатике
Отметьте истинные утверждения о языках программирования: 1). Языки программирования бывают универсальными и специализированными. 2). Язык программирования Python - универсальный язык программирования. 3).
Ответы (1)
Синвейн про информатику (1 строка информатика 2 строка два прилагательных 3 строка три глагола 4 строка фраза, несущая определённый смысл 5 строка вывод в одном слове) Стоки не должны рифмоваться
Ответы (1)
Уровень B. Задача M. Две одинаковые цифры рядом Напишите программу, которая определяет, верно ли, что введённое число содержит две одинаковых цифры, стоящие рядом (как, например, 221). Входные данные Входная строка содержит одно натуральное число.
Ответы (1)
Ввести слово и число раз (Ввод; паскаль, 3). Вывести это слово так: паскаль паскаль паскаль паскаль паскаль паскаль
Ответы (1)
В результате выполнения некого оператора переменные получили следующие значения a=3, c=9 укажите правильную запись данного оператора.
Ответы (1)